CloudLinux and Epel libsodium-devel conflicts

Modified on Tue, 12 Sep 2023 at 10:56 PM

You may find the following problem:

Error: Package: libsodium-devel-1.0.16-1.el7.x86_64 (cloudlinux-imunify360)

           Requires: libsodium(x86-64) = 1.0.16-1.el7

           Installed: libsodium-1.0.18-1.el7.x86_64 (@epel)

               libsodium(x86-64) = 1.0.18-1.el7

           Available: libsodium-1.0.5-1.el7.x86_64 (cloudlinux-x86_64-server-7)

               libsodium(x86-64) = 1.0.5-1.el7

           Available: libsodium-1.0.16-1.el7.x86_64 (cloudlinux-imunify360)

               libsodium(x86-64) = 1.0.16-1.el7

To resolve this, run this:

yum --disablerepo="epel" --enablerepo="cloudlinux-imunify360" downgrade libsodium

This will use the CloudLinux repo and downgrade libsodium to a compatible version. Once completed, you can proceed with the original command you intended to run.

Was this article helpful?

That’s Great!

Thank you for your feedback

Sorry! We couldn't be helpful

Thank you for your feedback

Let us know how can we improve this article!

Select atleast one of the reasons
CAPTCHA verification is required.

Feedback sent

We appreciate your effort and will try to fix the article